Can I use Patient Gateway with Macintosh, Firefox or Safari?

0
Posted

Can I use Patient Gateway with Macintosh, Firefox or Safari?

0

Before 2008, Patient Gateway was not certified for use on a Macintosh computer or Safari or Firefox web browser. Also, a downloaded ActiveX component had to be installed on the PC as part of the Mail Center application. With the current release, Patient Gateway is certified for use on both IBM-based PCs and Macintosh computers that meet the system requirements shown above.

Related Questions