I get an error while compiling because libpscrt.so.1 is missing, but I can find it in the lib64 directory. What is the problem?

0
Posted

I get an error while compiling because libpscrt.so.1 is missing, but I can find it in the lib64 directory. What is the problem?

0

The PathScale compilers require the 32-bit version of this library. Make sure this is in your library search path. This is covered in the PathScale Compiler Suite and Subscription Manager Install Guide, Section “Using Shared Libraries”. If you are installing a non-root tar file, you must configure the dynamic linker by hand. There are two ways to do this, depending on whether or not you have root privileges. If you do not have root privileges, (using a bash shell) type the following: $ export LD_LIBRARY_PATH=/lib/: /lib//32:$LD_LIBRARY_PATH If you have root privileges, point to shared files after a non-root tar file installation by adding the following lines to /etc/ld.so.conf (the order in which they appear does not matter): //lib/ //lib//32 After adding these lines, run the /sbin/ldconfig program to tell the dynamic linker about these new directories. You will need root pri

Related Questions