Ive attempted to open a v3.1 SSCE database file using the SSCE 3.5 runtime (still in beta) and it is failing?

0
Posted

Ive attempted to open a v3.1 SSCE database file using the SSCE 3.5 runtime (still in beta) and it is failing?

0

Despite using the same extension (ie .sdf) not only are SSCE 3.5 db file not backward compatible with older runtimes, SSCE 3.1 and earlier db files are not compatible with the new runtime. If you are building an application using the new SSCE 3.5 runtime you need to make sure you call the upgrade api on the SqlCeEngine class. Alternatively you can use Visual Studio 2008 to connect to an old database file, which will prompt you to upgrade.