What are the minimum system requirements for Track Magic?

0
Posted

What are the minimum system requirements for Track Magic?

0

Track Magic requires OS X 10.5 (Leopard) or later, and requires Rails 2.0 or later.

Related Questions