What if I don have the complex.h header file or C99 support on my platform?

file header Platform support
0
Posted

What if I don have the complex.h header file or C99 support on my platform?

0

Edit bebop_make/setup and find the line that says USE_C99_COMPLEX=1 Change 1 to 0, so that the line reads USE_C99_COMPLEX=0 Then, rebuild bebop_util and sparse_matrix_converter from scratch (make clean and then make again). This will let you build all the libraries, without requiring the complex number support provided by implementations of the C99 standard. You will, however, still be able to use our stub interface to complex arithmetic defined in bebop_util/include/bebop/util/complex.h. Q: But I’m running Cygwin with gcc 3.4.4 and I’ve heard that that version of gcc has complex arithmetic support! A: This is a known issue with Cygwin builds of gcc. I’d suggest reading the above entry in the FAQ.

Related Questions